We have been notified of an incident
Incident Report for Seedrs
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 01:27 BST
Investigating
Seedrs Automated Incident reporting tool has notified our team one of our services is not performing as expected, we have started to investigate the issue and will notify on this page further developments
Posted Oct 08, 2020 - 01:23 BST
This incident affected: Seedrs - Platform Website.