Pay by bank provider
Incident Report for Seedrs
Resolved
The provider has announced the service has been fully restored
Posted Jun 14, 2023 - 20:59 BST
Monitoring
The provider has notified that a fix has been deployed, they are monitoring but the service should be available
Posted Jun 14, 2023 - 20:02 BST
Update
The incident is still ongoing on the provider
Posted Jun 14, 2023 - 20:00 BST
Identified
We are seeing an increased number of errors in our Pay by bank service provider.
Progress can also be tracked at:
https://status.banked.com/
Posted Jun 14, 2023 - 19:12 BST
This incident affected: Payments Services (Banked).